[Buildroot] [RFC v1 1/2] libopenssl: bump version to 1.1.0h

Peter Seiderer ps.report at gmx.net
Wed May 2 21:25:28 UTC 2018


Hello Bernd,

On Sun, 29 Apr 2018 10:17:37 +0200, Bernd Kuhls <bernd.kuhls at t-online.de> wrote:

> Am Fri, 20 Apr 2018 08:29:52 -0700 schrieb Ryan Coe:
> 
> > I'm also getting the following error on host-libopenssl:  
> [...]
> > *** ERROR: package host-libopenssl installs executables without proper
> > RPATH:
> > ***   /home/ryan/devel/buildroot/output/host/bin/openssl  
> libopenssl-1.1.0h/NOTES.UNIX
> Hi,
> 
> adding
> 
> 	-Wl,-rpath,'$(HOST_DIR)/lib' \
> 
> to HOST_LIBOPENSSL_CONFIGURE_CMDS fixes the problem for me.
> For details read host-libopenssl-1.1.0h/NOTES.UNIX.

Thanks for the hint (work for me too), will add it to the next version of
the patch...

Regards,
Peter

> 
> Regards, Bernd
> 
> _______________________________________________
> buildroot mailing list
> buildroot at busybox.net
> http://lists.busybox.net/mailman/listinfo/buildroot




More information about the buildroot mailing list