[Buildroot] [PATCH v2/next 3/4] webkitgtk: update to version 2.20.0

Peter Korsgaard peter at korsgaard.com
Sat Mar 24 10:51:09 UTC 2018


>>>>> "Adrian" == Adrian Perez de Castro <aperez at igalia.com> writes:

 > Release notes:
 >     https://webkitgtk.org/2018/03/12/webkitgtk2.20.0-released.html

 > No corresponding WebKit Security Advisory (WSA) has been published
 > for now.

 > This also adds a dependency on the woff2 package. In previous versions
 > WebKitGTK+ bundled a known-to-work snapshot of its Git repository due to
 > upstream not providing releases. The situation has changed and releases
 > are now available, and the bundled copy of woff2 has been removed.

 > Last but not least, this patch selects BR2_PACKAGE_WEBP_DEMUX, which is
 > now required.

 > Signed-off-by: Adrian Perez de Castro <aperez at igalia.com>

 > ---
 > Changes v1 -> v2:
 >   - Marked as supported on AArch64, which is officially supported upstream.
 >   - Add upstream patch for fixing build failure with multimedia/XSLT
 >     support disabled.
 > ---
 >  ...ld-failure-when-ENABLE_VIDEO-ENABLE_WEB_A.patch | 32 ++++++++++++++++++++++
 >  package/webkitgtk/Config.in                        |  3 ++
 >  package/webkitgtk/webkitgtk.hash                   |  8 +++---
 >  package/webkitgtk/webkitgtk.mk                     |  4 +--

Your introductory mail talked about 3 additional patches needed for
aarch64 support, but I don't see them here?

-- 
Bye, Peter Korsgaard



More information about the buildroot mailing list