[Buildroot] [PATCH 09/10] python-jsonschema: needs python-functools32 when used with python 2.7

Peter Korsgaard peter at korsgaard.com
Fri Mar 9 19:17:00 UTC 2018


>From setup.py:

extras_require = {
    ..
    ":python_version=='2.7'": ["functools32"],

Signed-off-by: Peter Korsgaard <peter at korsgaard.com>
---
 package/python-jsonschema/Config.in | 1 +
 1 file changed, 1 insertion(+)

diff --git a/package/python-jsonschema/Config.in b/package/python-jsonschema/Config.in
index 7002653722..b547f4ae1a 100644
--- a/package/python-jsonschema/Config.in
+++ b/package/python-jsonschema/Config.in
@@ -1,5 +1,6 @@
 config BR2_PACKAGE_PYTHON_JSONSCHEMA
 	bool "python-jsonschema"
+	select BR2_PACKAGE_PYTHON_FUNCTOOLS32 if BR2_PACKAGE_PYTHON # runtime
 	help
 	  An implementation of JSON Schema validation for Python.
 
-- 
2.11.0



More information about the buildroot mailing list