[Buildroot] [PATCH v3 1/1] LIBLO : bump version to 0.29

Thomas Petazzoni thomas.petazzoni at bootlin.com
Mon Feb 12 15:54:03 UTC 2018


Hello,

On Mon, 12 Feb 2018 13:33:24 +0100, Alex B wrote:
> From: Alex <alexbaldwinmusic at gmail.com>
> 
> Starting from version 0.28, C++ wrappers are provided as well. The configure
> script appropriately detects the availability of a C++ compiler so no Buildroot
> changes are needed for this.
> 
> Building fails with --enable-ipv6 so --disable-ipv6 is needed in CONF_OPTS.
> This is known by liblo developers and building without ipv6 support is recomennded.
> 
> werror is kept on, so disable this with --disable-werror.
> 
> Patch to fix werror about redirect from sys/poll.h to poll.h
> 
> Liblo use's atomics, some architectures need explicit linking with libatomic. Added
> link to reflect this.
> 
> Included hash for license files.
> 
> Signed-off-by: Alex Baldwin <alexbaldwinmusic at gmail.com>

The liblo package has already been merged in the 'next' branch. So if
you want to send fixes, please send a patch on top of the current
'next' branch, i.e an incremental patch on top of what has already been
merged.

Thanks!

Thomas
-- 
Thomas Petazzoni, CTO, Bootlin (formerly Free Electrons)
Embedded Linux and Kernel engineering
http://bootlin.com



More information about the buildroot mailing list