[Buildroot] Drop support for Qt 5.6? [was: [RFC 1/2] qt5: bump latest version to 5.10.0]

Nimai Mahajan nimaim at gmail.com
Mon Feb 26 11:50:50 UTC 2018


On Feb 26, 2018 3:22 AM, "Peter Korsgaard" <peter at korsgaard.com> wrote:

>>>>> "Yann" == Yann E MORIN <yann.morin.1998 at free.fr> writes:

 > Nimai, All,
 > On 2018-02-25 18:10 +0000, Nimai Mahajan spake thusly:
 >> That's fine, but keep in mind this will never be as stable as their LTS
 >> releases, where they are constantly fixing bugs (5.9 is supposed to be
 >> supported til 2020, whereas 5.11 will come out in May and deprecate
5.10).
 >> Latest branch just keeps getting new > features thrown in it without
fixes
 >> to existing ones.

 > 5.6 is supposed to be maintained for three years after being introduced,
 > that is 2016-03-16 [0], which brings us toward 2019-03-16 as well, so a
 > bit more than a year still. ;-)

 > [0] https://www1.qt.io/qt-news/20578/

Correct, so this IMHO means we need to move to 5.9 for the LTS version
by the time we release Buildroot 2019.02, unless something changes - But
until then I would prefer to keep 5.6.


Sounds good. People that require this version in the future can simply
patch/port this package. At the very least, we should track the latest
5.9.x for BR 2018.02 LTS then (as it seems that release will include 5.6.x
and 5.9.x). I believe that is currently 5.9.4, with 5.9.5 coming in March.
Their patch version updates contain hundreds of bug fixes. Thanks.


--
Bye, Peter Korsgaard
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.busybox.net/pipermail/buildroot/attachments/20180226/509bd584/attachment.html>


More information about the buildroot mailing list