[Buildroot] [Jan Kundrát] [PATCH 1/3] systemd: Ensure /run and /var/run are the same on R/O rootfs

Jan Kundrát jan.kundrat at cesnet.cz
Thu Feb 15 12:42:13 UTC 2018

On čtvrtek 15. února 2018 0:13:37 CET, Christian Stewart wrote:
>> From: Jan Kundrát <jan.kundrat at cesnet.cz>
>> I'm leaving that one to someone who is more familiar with systemd and
>> buildroot conventions. My box now boots again, so I'm happy :).
>> [1] https://bugs.freedesktop.org/show_bug.cgi?id=101628
>> Signed-off-by: Jan Kundrát <jan.kundrat at cesnet.cz> ...
> I applied this patch, thanks. Unfortunately, it seems the problem is
> still occurring. Maybe it's a different problem?
> [   16.650294] systemd[1]: System is tainted: var-run-bad

Systemd reports that your /var/run is "bad". From what you wrote later, 
that's indeed the root cause which should be fixed.

Now, my patch fixed it only for a read-only rootfs. I assumed that 
everything worked well on a regular, r/w rootfs.

Can you please:

- state whether you're using a read-only or read-write rootfs 
- confirm that you completely nuked your build dir after applying this 
- check which packages actually provide your /var/run and /run, and how 
your setup looks like, i.e.:
  - grep ,./run build/packages-file-list.txt
  - grep ,./var build/packages-file-list.txt
  - grep dbus build/packages-file-list.txt | grep run
- how is your /etc/fstab?

> # ls /var/run/

These are not sufficient as they do not show the type of the individual 
items. `ls -al` should be better.

> If I link dbus like so:
> # ln -s /var/run/dbus/ /run/dbus
> It seems then that everything works fine.

Yeah, that's it. Based on how I read the code, though, this should already 
happen on a regular installation without a r/o rootfs...


More information about the buildroot mailing list