[Buildroot] [PATCH] package/solarus: bump to version 1.6.0

Romain Naour romain.naour at gmail.com
Fri Dec 28 15:25:31 UTC 2018


Hi Thomas,

Le 26/12/2018 à 21:33, Thomas Petazzoni a écrit :
> Hello Romain,
> 
> On Sun, 23 Dec 2018 14:33:17 +0100, Romain Naour wrote:
>> Here are the big features in Solarus 1.6:
>>
>>     * OpenGL backend and support for GLSL shaders (by Stdgregwar and Vlag)
> 
> I am a bit confused because this OpenGL dependency now seems to be
> mandatory, but you don't make it mandatory.
> 
> cmake/AddDependencies.cmake contains:
> 
> find_package(OpenGL)
> if(NOT OPENGL_FOUND)
>   find_package(OpenGLES2 REQUIRED)
> endif()
> 
> So it seems like it wants either OpenGL or OpenGL ES2, no?
> 
> In any case, if it's really not mandatory, passing the appropriate
> -D<blah>=OFF to explicitly disable OpenGL support would be good.

The dependency on OpenGL is new with this release.
Also the dependency on OpenGLES doesn't build.

Since I can test only with OpenGL support (GLX) I disabled entirely the openGLES
support (which doesn't seems to build).

Best regards,
Romain


> 
> Thanks,
> 
> Thomas
> 



More information about the buildroot mailing list