[Buildroot] Wifi not working - raspberrypi3_defconfig

Ola Oni oniola at gmail.com
Mon Dec 17 10:20:16 UTC 2018


Martin,

Cool thanks. I will give a try later.

Regards
Ola

On Mon, 17 Dec 2018, 10:18 Martin Bark <martin at barkynet.com wrote:

> Ola,
>
> You also need to include the rpi-wifi-firmware package (BR2_PACKAGE_RPI_WIFI_FIRMWARE)
> and make sure the brcmfmac module is installed.  You should see messages
> about brcmfmac in your logs
>
> Thanks
>
> Martin
>
> On Mon, 17 Dec 2018 at 07:50, Ola Oni <oniola at gmail.com> wrote:
>
>> Hi Peter,
>>
>> Thanks for your reply. I will try and configure later on today and report
>> back.
>>
>> May I add that when I use "ps" command wpa_supplicant process seem to be
>> listed as one of the process running so I assumed that "This is a giving"
>>
>> So I must have assumed wrong 😃
>>
>> Regards
>> Ola
>>
>> On Mon, 17 Dec 2018 at 07:16, Peter Seiderer <ps.report at gmx.net> wrote:
>>
>>> Hello Ola,
>>>
>>> On Sun, 16 Dec 2018 20:17:30 +0000, Ola Oni <oniola at gmail.com> wrote:
>>>
>>> > Hi Martin,
>>> >
>>> > I was advised to email you about my issue of not been able to get Wifi
>>> > working on raspberry pi 3 using buildroot 2018.11
>>> >
>>> > Below are the entry in my two files [/etc/network/interfaces and
>>> > /etc/wpa_supplicant.conf]
>>> >
>>> > # /etc/wpa_supplicant.conf <- filename
>>> > ctrl_interface=DIR=/var/run/wpa_supplicant GROUP=root
>>> > ctrl_interface_group=0
>>> > update_config=1
>>> >
>>> >      network={
>>> >              ssid="myssid"
>>> >              psk="mypassword"
>>> >              proto=WPA
>>> >              key_mgmt=WPA-PSK
>>> >              pairwise=CCMP
>>> >              auth_alg=OPEN
>>> >      }
>>> >
>>> > ########################################
>>> > # /etc/network/interfaces <- filename
>>> > # interface file auto-generated by buildroot
>>> >
>>> > auto lo
>>> > iface lo inet loopback
>>> >
>>> > auto eth0
>>> > iface eth0 inet dhcp
>>> >    pre-up /etc/network/nfs_check
>>> >    wait-delay 15
>>> >    hostname $(hostname)
>>> >
>>> > auto wlan0
>>> > iface wlan0 inet dhcp
>>> >          wireless-essid "myssid"
>>> >          wireless-key "mypassword"
>>> >          pre-up wpa_supplicant -i wlan0 -c /etc/wpa_supplicant.conf -B
>>> >          post-down killall -q wpa_supplicant
>>> >
>>> > Attached to this is email is the output from dmesg.
>>>
>>> Not much info, Wifi will definitely not work with raspberrypi3_defconfig
>>> out of the box (e.g. package BR2_PACKAGE_WPA_SUPPLICANT not enabled)...
>>>
>>> Regards,
>>> Peter
>>>
>>> >
>>> > Regards
>>> >
>>> > onio
>>> >
>>> >
>>> >
>>>
>>>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.busybox.net/pipermail/buildroot/attachments/20181217/c51599a7/attachment.html>


More information about the buildroot mailing list