[Buildroot] [PATCH] configs/bananapi_m2_ultra: add kernel headers version option

Peter Korsgaard peter at korsgaard.com
Sun Dec 16 19:36:56 UTC 2018


>>>>> "Thomas" == Thomas Petazzoni <thomas.petazzoni at bootlin.com> writes:

 > The bananapi_m2_plus defconfig uses a 4.18 kernel, but doesn't specify
 > anything for the kernel headers version, so the Buildroot default gets
 > used, which currently is 4.19. Since 4.19 is newer than 4.18,
 > Buildroot rightfully whines:

 >   Incorrect selection of kernel headers: expected 4.19.x, got 4.18.x

 > Let's fix this by telling this defconfig to use the headers from the
 > kernel, and that they are of version 4.18.

 > Fixes:

 >   https://gitlab.com/buildroot.org/buildroot/-/jobs/131216938

 > Signed-off-by: Thomas Petazzoni <thomas.petazzoni at bootlin.com>

Committed to 2018.11.x, thanks.

-- 
Bye, Peter Korsgaard


More information about the buildroot mailing list