[Buildroot] [git commit branch/2018.02.x] squashfs: do not force gzip support if lz4/xz/zstd is selected

Peter Korsgaard peter at korsgaard.com
Sun Dec 16 15:16:11 UTC 2018


commit: https://git.buildroot.net/buildroot/commit/?id=59d54e178a68d8997e5eff4297f02cf1eb4f7fa1
branch: https://git.buildroot.net/buildroot/commit/?id=refs/heads/2018.02.x

The logic to ensure at least one compression backend is selected was not
updated when lz4, xz and zstd were introduced -  Fix that.

Signed-off-by: Peter Korsgaard <peter at korsgaard.com>
Reviewed-by: Peter Seiderer <ps.report at gmx.net>
[Peter: add comment as suggested by Peter Seiderer]
Signed-off-by: Peter Korsgaard <peter at korsgaard.com>

(cherry picked from commit 84aeb4419f394b2eb11a22a962bc20e05b311b5f)
Signed-off-by: Peter Korsgaard <peter at korsgaard.com>
---
 package/squashfs/Config.in | 8 +++++++-
 1 file changed, 7 insertions(+), 1 deletion(-)

diff --git a/package/squashfs/Config.in b/package/squashfs/Config.in
index 70c0fc9808..b4d7becda3 100644
--- a/package/squashfs/Config.in
+++ b/package/squashfs/Config.in
@@ -2,7 +2,13 @@ config BR2_PACKAGE_SQUASHFS
 	bool "squashfs"
 	depends on BR2_TOOLCHAIN_HAS_THREADS
 	depends on BR2_USE_MMU # fork()
-	select BR2_PACKAGE_SQUASHFS_GZIP if !(BR2_PACKAGE_SQUASHFS_LZMA || BR2_PACKAGE_SQUASHFS_LZO)
+	# ensure at least on compression backend (defaults to gzip)
+	select BR2_PACKAGE_SQUASHFS_GZIP if !( \
+	       BR2_PACKAGE_SQUASHFS_LZ4 || \
+	       BR2_PACKAGE_SQUASHFS_LZMA || \
+	       BR2_PACKAGE_SQUASHFS_LZO || \
+	       BR2_PACKAGE_SQUASHFS_XZ || \
+	       BR2_PACKAGE_SQUASHFS_ZSTD)
 	help
 	  Tools to generate SquashFS filesystems.
 


More information about the buildroot mailing list