[Buildroot] [PATCH 1/1] dependencies.sh: Check for a host python version >= 2.7

Thomas Petazzoni thomas.petazzoni at bootlin.com
Sun Dec 16 15:02:25 UTC 2018


Hello,

On Sat, 15 Dec 2018 15:47:45 -0500, Adam Duskett wrote:

> On Sat, Dec 15, 2018 at 3:42 PM Baruch Siach <baruch at tkos.co.il> wrote:
> >
> > Hi Adam,
> >
> > aduskett at gmail.com writes:  
> > > From: Adam Duskett <Aduskett at gmail.com>
> > >
> > > Older distributions such as CentOS6 come with python2.6, which causes build
> > > failures in packages such as host-libglib2 because they require python2.7 or
> > > above.  
> >
> > Any reference to glib requirements? autobuilder failures?
> >  
> Not that I can see. I am not sure if any of the autobuilders are using
> CentOS6, however
> I noticed the crash when I was using a CentOS6 Docker container and
> decided to do some
> due diligence. :)

Please explain in the commit log which glib version has this
requirement, and which specific build failure you got.

Thanks,

Thomas
-- 
Thomas Petazzoni, CTO, Bootlin
Embedded Linux and Kernel engineering
https://bootlin.com


More information about the buildroot mailing list