[Buildroot] Buildroot autobuilder: make[2]: c: Command not found

Yann E. MORIN yann.morin.1998 at free.fr
Wed Dec 5 10:35:05 UTC 2018


Alexey, All,

On 2018-12-05 09:06 +0100, Yann E. MORIN spake thusly:
> On 2018-12-05 07:29 +0000, Alexey Brodkin spake thusly:
> > Just got a report about failed build, see
> > http://autobuild.buildroot.net/results/cb5/cb555a124bb3bdb9c5a3465673c21022d94cf2ca/
> > 
> > But there's definitely something strange there as instead of "gcc" command "c" gets executed,
> > see http://autobuild.buildroot.net/results/cb5/cb555a124bb3bdb9c5a3465673c21022d94cf2ca//build-end.log:
> > ------------------------>8-----------------------
> > c -o option.o -pipe -ffunction-sections -O2 -g  -I/home/buildroot/autobuild/run/instance-0/output/build/qt5base-5.6.3/qmake
> [--SNIP--]
> > make[2]: c: Command not found
> I've spun a build here to investigate. If I can't reproduce lcoally, I'll
> see to try and reproduce it on my autobuild instance.

Unsurprisingly, I was not able to reproduce on my machine, but it indeed
breaks systematically on my autobuilder (i.e. it is not a fluke or a
parallel build issue.

I reverted c2ea056a1b (package/qt5/qt5base: use ccache for building host
code) and qt5base now builds again.

I'm investigating...

Regards,
Yann E. MORIN.

-- 
.-----------------.--------------------.------------------.--------------------.
|  Yann E. MORIN  | Real-Time Embedded | /"\ ASCII RIBBON | Erics' conspiracy: |
| +33 662 376 056 | Software  Designer | \ / CAMPAIGN     |  ___               |
| +33 223 225 172 `------------.-------:  X  AGAINST      |  \e/  There is no  |
| http://ymorin.is-a-geek.org/ | _/*\_ | / \ HTML MAIL    |   v   conspiracy.  |
'------------------------------^-------^------------------^--------------------'


More information about the buildroot mailing list