[Buildroot] [PATCH v2,1/1] libbsd: fix display of comment

Thomas Petazzoni thomas.petazzoni at bootlin.com
Mon Dec 3 21:29:05 UTC 2018


Hello,

On Mon,  3 Dec 2018 22:03:20 +0100, Fabrice Fontaine wrote:
> Commit e13855c48f21eaee07a81f8b02678839be274a45 wrongly added
> depends on BR2_TOOLCHAIN_USES_UCLIBC && !BR2_USE_MMU
> to display the comment "libbsd needs a toolchain w/ threads, wchar"
> The same error has also been made for minizip
> 
> To fix this issue, move dependency
> !(BR2_TOOLCHAIN_USES_UCLIBC && !BR2_USE_MMU) under
> BR2_PACKAGE_LIBBSD_ARCH_SUPPORTS
> 
> Signed-off-by: Fabrice Fontaine <fontaine.fabrice at gmail.com>
> ---
> Changes v1 -> v2 (after review of Thomas Petazzoni):
>  - move dependency
>    !(BR2_TOOLCHAIN_USES_UCLIBC && !BR2_USE_MMU) under
>    BR2_PACKAGE_LIBBSD_ARCH_SUPPORTS

Applied to master, thanks.

Thomas
-- 
Thomas Petazzoni, CTO, Bootlin
Embedded Linux and Kernel engineering
https://bootlin.com


More information about the buildroot mailing list