[Buildroot] [PATCH 1/1] libbsd: fix display of comment

Fabrice Fontaine fontaine.fabrice at gmail.com
Sun Dec 2 10:25:51 UTC 2018


Commit e13855c48f21eaee07a81f8b02678839be274a45 wrongly added
depends on BR2_TOOLCHAIN_USES_UCLIBC && !BR2_USE_MMU
to display the comment "libbsd needs a toolchain w/ threads, wchar"

Set the correct dependency:
depends on !(BR2_TOOLCHAIN_USES_UCLIBC && !BR2_USE_MMU)

Signed-off-by: Fabrice Fontaine <fontaine.fabrice at gmail.com>
---
 package/libbsd/Config.in | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

diff --git a/package/libbsd/Config.in b/package/libbsd/Config.in
index ba5e5cbcfa..ce50ec37de 100644
--- a/package/libbsd/Config.in
+++ b/package/libbsd/Config.in
@@ -24,5 +24,5 @@ config BR2_PACKAGE_LIBBSD
 
 comment "libbsd needs a toolchain w/ threads, wchar"
 	depends on BR2_PACKAGE_LIBBSD_ARCH_SUPPORTS
-	depends on BR2_TOOLCHAIN_USES_UCLIBC && !BR2_USE_MMU
+	depends on !(BR2_TOOLCHAIN_USES_UCLIBC && !BR2_USE_MMU)
 	depends on !BR2_TOOLCHAIN_HAS_THREADS || !BR2_USE_WCHAR
-- 
2.17.1



More information about the buildroot mailing list