[Buildroot] [PATCH v3] gst1-plugins-bad: fix build against openjpeg 2.2

Aleksander Morgado aleksander at aleksander.es
Mon Sep 11 10:00:25 UTC 2017


>> Do you have host-gettext explicitly enabled? Could you attach the output of
>
> Tested with your patch applied, my patch applied with the following changes:
>
> --- a/package/gstreamer1/gst1-plugins-bad/gst1-plugins-bad.mk
> +++ b/package/gstreamer1/gst1-plugins-bad/gst1-plugins-bad.mk
> @@ -15,7 +15,7 @@ GST1_PLUGINS_BAD_LICENSE = LGPL-2.0+, LGPL-2.1+
>
>  # patch 0001-openjpeg-Fix-build-against-openjpeg-2.2.patch touches configure.ac
>  GST1_PLUGINS_BAD_AUTORECONF = YES
> -GST1_PLUGINS_BAD_GETTEXTIZE = YES
> +#GST1_PLUGINS_BAD_GETTEXTIZE = YES
>
>  GST1_PLUGINS_BAD_CONF_OPTS = \
>         --disable-examples \
> @@ -65,7 +65,7 @@ GST1_PLUGINS_BAD_CONF_OPTS += \
>         --disable-gtk3 \
>         --disable-qt
>
> -GST1_PLUGINS_BAD_DEPENDENCIES = gst1-plugins-base gstreamer1
> +GST1_PLUGINS_BAD_DEPENDENCIES = host-gettext gst1-plugins-base gstreamer1
>
>  ifeq ($(BR2_PACKAGE_RPI_USERLAND),y)
>  # RPI has odd locations for several required headers.
>
>
>> the make command when rebuilding the package?
>
> Yes, see attachment make-gst1_plugins-bad.log.gz.
>

I'll try to reproduce this issue myself once I find some free time,
and will let you know what I find. In the meantime, just go on and
merge the latest patch if it's ok, and sorry for hijacking the thread
with the gettext vs autopoint issue :)


-- 
Aleksander
https://aleksander.es



More information about the buildroot mailing list