[Buildroot] [PATCH 1/1] host-mariadb: add host-openssl dependency

Ryan Coe bluemrp9 at gmail.com
Thu Jul 27 14:10:05 UTC 2017


Adam,


On 7/27/2017 6:35 AM, Adam Duskett wrote:
> On Fedora26, openssl 1.1.x is included by default.  This causes build errors
> when building the host variant of mariadb. Adding host-openssl as a dependency
> fixes this issue.
>
> Signed-off-by: Adam Duskett <aduskett at gmail.com>
> ---
>   package/mariadb/mariadb.mk | 3 +++
>   1 file changed, 3 insertions(+)
>
> diff --git a/package/mariadb/mariadb.mk b/package/mariadb/mariadb.mk
> index 1d6c2bcc4..8004709c7 100644
> --- a/package/mariadb/mariadb.mk
> +++ b/package/mariadb/mariadb.mk
> @@ -22,6 +22,9 @@ MARIADB_DEPENDENCIES = \
>   	libxml2 \
>   	readline
>   
> +HOST_MARIADB_DEPENDENCIES = \
> +	host-openssl
> +
>   # We won't need unit tests
>   MARIADB_CONF_OPTS += -DWITH_UNIT_TESTS=0
>   
Acked-by: Ryan Coe <bluemrp9 at gmail.com>



More information about the buildroot mailing list