[Buildroot] [PATCH v2,1/1] lxc: add dependency on gnutls

Peter Korsgaard peter at korsgaard.com
Mon Jan 30 15:18:25 UTC 2017


>>>>> "Fabrice" == Fabrice Fontaine <fontaine.fabrice at gmail.com> writes:

 > lxc can use gnutls for various checksumming so add a dependency on it if
 > package is selected

 > Signed-off-by: Fabrice Fontaine <fabrice.fontaine at orange.com>
 > ---
 > Changes v1 -> v2 (after review of Thomas Petazzoni):
 >  - Get upstream patch that add --enable-gnutls option

Committed, thanks. I see upstream has releases 2.0.7 so it would be nice
to update to that and get rid of autoreconf.

I also noticed that your patch hardcodes -lgnutls instead of using
pkg-config to figure out the exact libraries needed. With lxc not
allowing static linking this it probably good enough, but it would have
been nicer to do it "right".

-- 
Bye, Peter Korsgaard


More information about the buildroot mailing list