[Buildroot] [PATCH] clamav: break configure breakage after zlib 1.2.10 version bump

Peter Korsgaard peter at korsgaard.com
Wed Jan 4 16:03:50 UTC 2017


>>>>> "Peter" == Peter Korsgaard <peter at korsgaard.com> writes:

 > Fixes:
 > http://autobuild.buildroot.net/results/b6b/b6ba2dfb42ee41ed0b8304aa8c78645245f3b341/
 > http://autobuild.buildroot.net/results/eef/eef9a2dda2c172cd600dc74c1e5e60476d92280d/
 > http://autobuild.buildroot.net/results/827/82798118795aa6334b4dd6eac06777682131da7f/

 > The clamav configure script by default checks for old zlib versions with
 > known vulnerabilities and errors out if found:

 > configure: error: The installed zlib version may contain a security bug.
 > Please upgrade to 1.2.2 or later: http://www.zlib.net.  You can omit this
 > check with --disable-zlib-vcheck but DO NOT REPORT any stability issues
 > then!

 > The check is unfortunately not very robust as it simply checks for a version
 > string matching '1.2.1' (which 1.2.10 does):

 > vuln=`grep "ZLIB_VERSION \"1.2.1" $ZLIB_HOME/include/zlib.h`

 > As a workaround, pass --disable-zlib-vcheck to skip this check.

 > Signed-off-by: Peter Korsgaard <peter at korsgaard.com>

Committed after fixing subject, thanks.

-- 
Bye, Peter Korsgaard


More information about the buildroot mailing list