[Buildroot] [PATCH 3/4] swupdate: improved help text for Lua support

Thomas Petazzoni thomas.petazzoni at free-electrons.com
Mon Jul 25 07:32:53 UTC 2016


Hello,

On Sun, 24 Jul 2016 16:27:38 -0700, Jordan Yelloz wrote:

> -	  * Select BR2_PACKAGE_LUA if you want to have Lua support.
> +	  * Select BR2_PACKAGE_LUA or BR2_PACKAGE_LUAJIT if you want to have Lua
> +	    support.
> +	    CONFIG_HANDLER_IN_LUA is not supported in LuaJIT or Lua 5.1.
> +	    swupdate must be manually configured with CONFIG_LUAVERSION="jit-5.1"
> +	    to link against luajit.

What does this last sentence means?

Thomas
-- 
Thomas Petazzoni, CTO, Free Electrons
Embedded Linux, Kernel and Android engineering
http://free-electrons.com


More information about the buildroot mailing list