[Buildroot] [PATCH v7 10/13] Vivante drivers: bump to version 3.10.17-1.0.1

Thomas Petazzoni thomas.petazzoni at free-electrons.com
Tue May 12 08:18:13 UTC 2015


Dear Gary Bisson,

On Tue, 12 May 2015 09:56:10 +0200, Gary Bisson wrote:

> > Since this package seems to be incompatible with kernels < 3.10.54, maybe we
> > should provide imx-gpu-viv AND gpu-viv-bin-mx6q, no?
> 
> Well the gpu-viv-bin-mx6q is only good for 3.10.17 whereas the new
> imx-gpu-viv apparently works for both 3.10.53 and 3.14.28. Also most
> of the kernels offered by manufacturers are now 3.10.53 or above. But
> let's consider the option, wouldn't it be a headache for packages that
> depend on it such as gst1-imx or xdriver_xf86-video-imx-viv? I guess
> it'd need to check on the kernel headers versions to know which
> package it depends on.

We could use a virtual package, but it indeed seems to be too much of
an headache. If the new version of the i.MX6 GPU drivers support both
3.10.53 and 3.14.28, then I think we should package just this latest
version. People running 3.10.17 should upgrade :)

Best regards,

Thomas
-- 
Thomas Petazzoni, CTO, Free Electrons
Embedded Linux, Kernel and Android engineering
http://free-electrons.com


More information about the buildroot mailing list