[Buildroot] [PATCH 2/3] libgtk2: drop libxcomposite duplicate dep

Gustavo Zacarias gustavo at zacarias.com.ar
Mon Mar 30 20:43:37 UTC 2015


It's got a mandatory dependency on libxcomposite and an autodep on it.
AFAIK it's mandatory so drop the autodep.

Signed-off-by: Gustavo Zacarias <gustavo at zacarias.com.ar>
---
 package/libgtk2/libgtk2.mk | 4 ----
 1 file changed, 4 deletions(-)

diff --git a/package/libgtk2/libgtk2.mk b/package/libgtk2/libgtk2.mk
index 39c629c..ceb4864 100644
--- a/package/libgtk2/libgtk2.mk
+++ b/package/libgtk2/libgtk2.mk
@@ -111,10 +111,6 @@ ifeq ($(BR2_PACKAGE_XLIB_LIBXFIXES),y)
 	LIBGTK2_DEPENDENCIES += xlib_libXfixes
 endif
 
-ifeq ($(BR2_PACKAGE_XLIB_LIBXCOMPOSITE),y)
-	LIBGTK2_DEPENDENCIES += xlib_libXcomposite
-endif
-
 ifeq ($(BR2_PACKAGE_XLIB_LIBXDAMAGE),y)
 	LIBGTK2_DEPENDENCIES += xlib_libXdamage
 endif
-- 
2.0.5




More information about the buildroot mailing list