[Buildroot] [V2 2/2] ljlinenoise: remove dependency on some architecture

Francois Perrad fperrad at gmail.com
Sat Mar 21 12:01:38 UTC 2015


ljsyscall is available for all arch supported by LuaJIT.

Signed-off-by: Francois Perrad <francois.perrad at gadz.org>
---
 package/ljlinenoise/Config.in | 3 ---
 1 file changed, 3 deletions(-)

diff --git a/package/ljlinenoise/Config.in b/package/ljlinenoise/Config.in
index 17be1be..be83bdb 100644
--- a/package/ljlinenoise/Config.in
+++ b/package/ljlinenoise/Config.in
@@ -4,8 +4,6 @@ config BR2_PACKAGE_LJLINENOISE
 	select BR2_PACKAGE_LJSYSCALL
 	# ljsyscall is specifically for LuaJIT, not Lua.
 	depends on BR2_PACKAGE_LUAJIT
-	# ljsyscall is only available for some target architectures
-	depends on BR2_i386 || BR2_x86_64 || BR2_powerpc || BR2_arm || BR2_armeb
 	help
 	  ljlinenoise is a pure LuaJIT port of linenoise,
 	  a small alternative to readline and libedit.
@@ -14,4 +12,3 @@ config BR2_PACKAGE_LJLINENOISE
 
 comment "ljlinenoise needs LuaJIT"
 	depends on !BR2_PACKAGE_LUAJIT
-	depends on BR2_i386 || BR2_x86_64 || BR2_powerpc || BR2_arm || BR2_armeb
-- 
2.1.0




More information about the buildroot mailing list