[Buildroot] [PATCH] package/numactl: upgrade to 2.0.10

Steven Noonan steven at uplinklabs.net
Thu Mar 19 05:30:30 UTC 2015


On Wed, Mar 18, 2015 at 10:26 PM, Baruch Siach <baruch at tkos.co.il> wrote:
> Hi Steven,
>
> On Wed, Mar 18, 2015 at 08:48:06PM -0700, Steven Noonan wrote:
>> Signed-off-by: Steven Noonan <steven at uplinklabs.net>
>
> This is a non trivial version bump. Please explain here that the package now
> uses the autotools infrastructure.
>
>> ---
>>  package/numactl/numactl.mk | 12 +++---------
>>  1 file changed, 3 insertions(+), 9 deletions(-)
>>
>> diff --git a/package/numactl/numactl.mk b/package/numactl/numactl.mk
>> index f36a1b3..042f2d8 100644
>> --- a/package/numactl/numactl.mk
>> +++ b/package/numactl/numactl.mk
>> @@ -4,17 +4,11 @@
>>  #
>>  ################################################################################
>>
>> -NUMACTL_VERSION = 2.0.9
>> +NUMACTL_VERSION = 2.0.10
>>  NUMACTL_SITE = ftp://oss.sgi.com/www/projects/libnuma/download
>>  NUMACTL_LICENSE = LGPLv2.1 (libnuma), GPLv2 (programs)
>>  NUMACTL_LICENSE_FILES = README
>>
>> -define NUMACTL_BUILD_CMDS
>> -     $(MAKE) $(TARGET_CONFIGURE_OPTS) -C $(@D)
>> -endef
>> +NUMACTL_AUTORECONF = YES
>
> Why? Please add inline comment clarifying that.

Fair enough. The reason is because the numactl tarball doesn't already
contain a configure script, but does contain configure.ac,
Makefile.am, etc. Will add a comment.



More information about the buildroot mailing list