[Buildroot] [PATCH v3 5/8] qt5base: remove postgresql introduced uclibc dependency for the PostgresSQL plugin

Peter Seiderer ps.report at gmx.net
Tue Mar 10 19:59:41 UTC 2015


Signed-off-by: Peter Seiderer <ps.report at gmx.net>
---
Changes v1 --> v2:
  - added (thanks to Baruch Siach for the hint)
---
 package/qt5/qt5base/Config.in | 4 ----
 1 file changed, 4 deletions(-)

diff --git a/package/qt5/qt5base/Config.in b/package/qt5/qt5base/Config.in
index 99e249f..17ed5db 100644
--- a/package/qt5/qt5base/Config.in
+++ b/package/qt5/qt5base/Config.in
@@ -60,14 +60,10 @@ config BR2_PACKAGE_QT5BASE_MYSQL
 config BR2_PACKAGE_QT5BASE_PSQL
 	bool "PostgreSQL Plugin"
 	select BR2_PACKAGE_POSTGRESQL
-	depends on BR2_TOOLCHAIN_USES_GLIBC
 	help
 	  Build PostgreSQL plugin
 	  If unsure, say n.
 
-comment "PostgreSQL needs an (e)glibc toolchain"
-	depends on !BR2_TOOLCHAIN_USES_GLIBC
-
 choice
 	prompt "SQLite 3 support"
 	default BR2_PACKAGE_QT5BASE_SQLITE_NONE
-- 
2.1.4




More information about the buildroot mailing list