[Buildroot] [PATCH 1/1] package/libseccomp: needs headers >= 3.12

Thomas Petazzoni thomas.petazzoni at free-electrons.com
Tue Mar 31 21:33:39 UTC 2015


Dear Baruch Siach,

On Tue, 31 Mar 2015 20:11:43 +0300, Baruch Siach wrote:

> Now I see. It is kernel commit 909e3ee41 that adds both EM_ARM and EM_AARCH64 
> to a generic header. In this case maybe patching the code is preferable. 
> Something like:
> 
> #ifndef EM_ARM
> #define EM_ARM 40
> #endif
> 
> #ifndef EM_AARCH64
> #define EM_AARCH64 183
> #endif
> 
> Something like that should be acceptable upstream.

Agreed, this would allow to remove the dependency of libseccomp on >=
3.12. Though I personally don't mind that much, since libseccomp does
not have any reverse dependencies, except systemd (for which it is an
optional dependency), and systemd itself already depends on having a
fairly recent set of kernel headers.

Thomas
-- 
Thomas Petazzoni, CTO, Free Electrons
Embedded Linux, Kernel and Android engineering
http://free-electrons.com


More information about the buildroot mailing list