[Buildroot] [PATCH v2 2/3] libgtk2: drop libxcomposite mandatory dep

Gustavo Zacarias gustavo at zacarias.com.ar
Mon Mar 30 21:16:29 UTC 2015


It's not selected, not required and duplicate with the autodep.

Signed-off-by: Gustavo Zacarias <gustavo at zacarias.com.ar>
---
 package/libgtk2/libgtk2.mk | 3 +--
 1 file changed, 1 insertion(+), 2 deletions(-)

diff --git a/package/libgtk2/libgtk2.mk b/package/libgtk2/libgtk2.mk
index 39c629c..c92bbd2 100644
--- a/package/libgtk2/libgtk2.mk
+++ b/package/libgtk2/libgtk2.mk
@@ -82,8 +82,7 @@ LIBGTK2_CONF_OPTS += \
 	--x-libraries=$(STAGING_DIR)/usr/lib \
 	--with-gdktarget=x11
 LIBGTK2_DEPENDENCIES += \
-	xlib_libXcomposite fontconfig xlib_libX11 \
-	xlib_libXext xlib_libXrender
+	fontconfig xlib_libX11 xlib_libXext xlib_libXrender
 
 ifeq ($(BR2_PACKAGE_XLIB_LIBXINERAMA),y)
 	LIBGTK2_CONF_OPTS += --enable-xinerama
-- 
2.0.5



More information about the buildroot mailing list