[Buildroot] [Bug 7971] New: python-flask, python-flask. No module named zlib

bugzilla at busybox.net bugzilla at busybox.net
Tue Mar 24 20:43:41 UTC 2015


           Summary: python-flask, python-flask. No module named zlib
           Product: buildroot
           Version: 2015.02
          Platform: PC
        OS/Version: Linux
            Status: NEW
          Severity: normal
          Priority: P5
         Component: Other
        AssignedTo: unassigned at buildroot.uclibc.org
        ReportedBy: nikita_23k at mail.ru
                CC: buildroot at uclibc.org
   Estimated Hours: 0.0

Target: raspberry pi 1
Host: Linux Mint 17.1

I'm trying to run a web-server using python-flask. A similar problem with

My steps:
1. cd /home/n1/test
2. download buildroot
3. cd buildroot
4. make nconfig # add nano, python (2.*), python-flask (zlib added auto)
,wchar, etc (for rpi)
6. make
7. upload to sd card

When I run the project (python-flask) on rpi:

from flask import Flask
app = Flask(__name__)
def hello():
  return "Hello World!"

I get an error:
 traceback (most recent call last):
   File "test.py", line 1 in, in <module>
     from flask import Flask
line 17, in <module>
line 154, in <module>
   ImportError: No module named zlib

I tried to compile with the help of https://github.com/gamaral/rpi-buildroot ,
but got the same error. My bug report:

Configure bugmail: https://bugs.busybox.net/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are on the CC list for the bug.

More information about the buildroot mailing list