[Buildroot] [PATCH v2 3/4] package/avrdude: depends on libftdi1 instead of libftdi

Samuel Martin s.martin49 at gmail.com
Tue Mar 17 16:24:07 UTC 2015


Hi Thomas,

On Mon, Mar 16, 2015 at 2:15 PM, Thomas Petazzoni
<thomas.petazzoni at free-electrons.com> wrote:
> Dear Samuel Martin,
>
> On Sun, 8 Mar 2015 18:03:09 +0100, Samuel Martin wrote:
>
>> > How do you tell avrdude to link with libftdi1 and not libftdi when both are
>> > built? The same question goes for openocd.
>>
>> Both avrdude and openocd first check for libftdi1, and use it if any,
>> otherwise check for libftdi.
>> So, unless I'm missing something this is ok; but that's true I forgot
>> to mention this point in the commit log. :-/
>
> So the patch should actually be:
>
> ifeq ($(BR2_PACKAGE_LIBFTDI1),y)
> AVRDUDE_DEPENDENCIES += libftdi1
> else ifeq ($(BR2_PACKAGE_LIBFTDI),y)
> AVRDUDE_DEPENDENCIES += libftdi
> endif

Well, my first thought was simply to drop the libftdi support because
of the additional dependency it pulls (libusb-compat):
- with dependency on libftdi:
  arvdude -> libftdi -> libusb-compat -> libusb
- with dependency on libftdi1:
  arvdude -> libftdi1 -> libusb

Note that, the configure script uses libftdi1 (if found) in priority
over libftdi.

>
> Can you fix and resend?

On it.

>
> Thanks,
>
> Thomas
> --
> Thomas Petazzoni, CTO, Free Electrons
> Embedded Linux, Kernel and Android engineering
> http://free-electrons.com

Regards,

-- 
Samuel


More information about the buildroot mailing list