[Buildroot] [PATCH] cups: deprecate package due to security issues

Gustavo Zacarias gustavo at zacarias.com.ar
Fri Mar 6 14:30:29 UTC 2015


On 03/06/2015 11:09 AM, Thomas Petazzoni wrote:
> Any reason why this is done on the comment only, and not on the package
> itself?
> 
> Other than that, I'd personally be in favor of this deprecation.
> Hopefully it will encourage someone to step up and upgrade cups.

I just used it as a mark for when/if removing it, since they all depend
on BR2_PACKAGE_CUPS being selected, not needed really.
Ideally something like BR2_LEGACY would be best for the users to get a
big warning, problem is that introducing it for just one package isn't
very useful, and it would set a precedent for other packages to lag
behind as well.
Regards.



More information about the buildroot mailing list