[Buildroot] [PATCH 2/2] uclibc: remove Xtensa specific version

Max Filippov jcmvbkbc at gmail.com
Sun Jun 14 12:08:27 UTC 2015


On Sat, Jun 13, 2015 at 8:21 PM, Thomas Petazzoni
<thomas.petazzoni at free-electrons.com> wrote:
> Since we now have uClibc-ng, and it is used as the default uClibc
> version, there is no real need to keep the Xtensa version: this
> version is just a specific Git revision of uClibc master branch, and
> uClibc-ng is also based on uClibc master branch.
>
> In addition, since in the choice of uClibc versions, uClibc-ng is
> already *before* the Xtensa specific version, uClibc-ng has in fact
> already been the default uClibc version for Xtensa since uClibc-ng
> support was introduced.
>
> See for example:
>
>   http://autobuild.buildroot.org/results/c85/c854fae31d82e0f11d5a8b5bfc196c29bd7e21db/config
>
> for a build on Xtensa with the internal toolchain, where in fact
> uClibc-ng is used instead of the Xtensa specific version.

Yes, been using it for a while, got no issues so far.

> Signed-off-by: Thomas Petazzoni <thomas.petazzoni at free-electrons.com>
> Cc: Max Filippov <jcmvbkbc at gmail.com>
> Cc: Waldemar Brodkorb <wbx at openadk.org>
> ---
>  package/uclibc/Config.in | 7 -------
>  package/uclibc/uclibc.mk | 3 ---
>  2 files changed, 10 deletions(-)

Patch directory for that version of uClibc can go away as well, I guess.
Reviewed-by: Max Filippov <jcmvbkbc at gmail.com>

-- 
Thanks.
-- Max


More information about the buildroot mailing list