[Buildroot] [PATCH v4] moarvm: new package

Thomas Petazzoni thomas.petazzoni at free-electrons.com
Sat Jun 6 15:05:08 UTC 2015


Dear François Perrad,

On Sat, 6 Jun 2015 11:03:38 +0200, François Perrad wrote:

> > +MOARVM_DEPENDENCIES = host-luajit libuv libatomic_ops
> 
> host-luajit seems overkill.

Why? Lua is not part of the core dependencies of Buildroot, which are
mandatory to run Buildroot. So if it's not part of these core
dependencies, and used for the build process of moarvm, then it should
be added as a dependency of that package.

Otherwise the build will fail for users that don't have Luajit
installed on their machine, like is the case for several of the
autobuilders.

Best regards,

Thomas
-- 
Thomas Petazzoni, CTO, Free Electrons
Embedded Linux, Kernel and Android engineering
http://free-electrons.com


More information about the buildroot mailing list