[Buildroot] [PATCH v2 2/2] luacrypto: remove duplicate dependency on luainterpreter

François Perrad francois.perrad at gadz.org
Mon Feb 2 19:59:56 UTC 2015


2015-02-02 16:35 GMT+01:00 Thomas De Schampheleire <patrickdepinguin at gmail.com>:
> From: Thomas De Schampheleire <thomas.de.schampheleire at gmail.com>
>
> The luarocks package infrastructure already adds a dependency on
> luainterpreter, so it is not necessary to add it in luacrypto.
>
> Signed-off-by: Thomas De Schampheleire <thomas.de.schampheleire at gmail.com>
Acked-by: Francois Perrad <francois.perrad at gadz.org>

> ---
>  package/luacrypto/luacrypto.mk | 2 +-
>  1 file changed, 1 insertion(+), 1 deletion(-)
>
> diff --git a/package/luacrypto/luacrypto.mk b/package/luacrypto/luacrypto.mk
> index 42e20af..b0e972c 100644
> --- a/package/luacrypto/luacrypto.mk
> +++ b/package/luacrypto/luacrypto.mk
> @@ -9,6 +9,6 @@ LUACRYPTO_VERSION = $(LUACRYPTO_VERSION_UPSTREAM)-1
>  LUACRYPTO_SUBDIR = luacrypto-$(LUACRYPTO_VERSION_UPSTREAM)
>  LUACRYPTO_LICENSE = MIT
>  LUACRYPTO_LICENSE_FILES = $(LUACRYPTO_SUBDIR)/COPYING
> -LUACRYPTO_DEPENDENCIES = luainterpreter openssl
> +LUACRYPTO_DEPENDENCIES = openssl
>
>  $(eval $(luarocks-package))
> --
> 1.8.5.1
>
> _______________________________________________
> buildroot mailing list
> buildroot at busybox.net
> http://lists.busybox.net/mailman/listinfo/buildroot


More information about the buildroot mailing list