[Buildroot] [PATCH 1/1] package/upmpdcli: bump to version 0.8.1

Peter Korsgaard jacmet at uclibc.org
Thu Sep 25 20:59:45 UTC 2014


>>>>> "Jörg" == Jörg Krause <jkrause at posteo.de> writes:

 > Bumping to version 0.8.1 requires a change of the uclibc patch.
 > Signed-off-by: Jörg Krause <jkrause at posteo.de>
 > ---
 >  package/upmpdcli/upmpdcli-0001-uclibc-fixes.patch | 59 ++++++++++++++---------
 >  package/upmpdcli/upmpdcli.mk                      |  2 +-
 >  2 files changed, 36 insertions(+), 25 deletions(-)

Sorry, it doesn't seem to build here with uClibc (missing header?):

libtool: compile:  /home/peko/source/buildroot/output/host/usr/bin/arm-linux-g++ -DHAVE_CONFIG_H -I. -I./libupnpp -DDEBUG -g -Wall -DDATADIR=\"/usr/share/upmpdcli\" -DCONFIGDIR=\"/etc\" -D_LARGEFILE_SOURCE -D_LARGEFILE64_SOURCE -D_FILE_OFFSET_BITS=64 -std=c++0x -D_LARGEFILE_SOURCE -D_LARGEFILE64_SOURCE -D_FILE_OFFSET_BITS=64 -pipe -Os -c libupnpp/control/description.cxx -o libupnpp/control/description.o >/dev/null 2>&1
libupnpp/control/avtransport.cxx: In member function 'void UPnPClient::AVTransport::evtCallback(const std::unordered_map<std::basic_string<char>, std::basic_string<char> >&)':
libupnpp/control/avtransport.cxx:159:63: error: 'atoi' was not declared in this scope
Makefile:800: recipe for target 'libupnpp/control/avtransport.lo' failed
make[1]: *** [libupnpp/control/avtransport.lo] Error 1

-- 
Bye, Peter Korsgaard



More information about the buildroot mailing list