[Buildroot] [PATCH 1/2] coreutils: Do not install uptime

Thomas Petazzoni thomas.petazzoni at free-electrons.com
Wed Sep 10 20:45:29 UTC 2014


Dear Vicente Olivert Riera,

On Wed, 10 Sep 2014 15:30:05 +0100, Vicente Olivert Riera wrote:
> coreutils' uptime doesn't work and its execution fails with a message
> like this one:
> 
>   uptime: couldn't get boot time: No such file or directory
> 
> busybox and procps-ng provide a working alternative.
> 
> This is a common old problem as we can see here:
> 
>   https://lists.openwrt.org/pipermail/openwrt-devel/2011-March/010006.html
> 
> Signed-off-by: Vicente Olivert Riera <Vincent.Riera at imgtec.com>
> Reviewed-by: Markos.Chandras <Markos.Chandras at imgtec.com>
> ---
>  package/coreutils/coreutils.mk |    3 ++-
>  1 files changed, 2 insertions(+), 1 deletions(-)
> 
> diff --git a/package/coreutils/coreutils.mk b/package/coreutils/coreutils.mk
> index 07a1347..7457b79 100644
> --- a/package/coreutils/coreutils.mk
> +++ b/package/coreutils/coreutils.mk
> @@ -61,7 +61,8 @@ COREUTILS_CONF_ENV = ac_cv_c_restrict=no \
>  		PERL=missing
>  
>  COREUTILS_CONF_OPT = --disable-rpath \
> -		--enable-install-program=hostname
> +		--enable-install-program=hostname \
> +		--enable-no-install-program=uptime

I think this is not the proper fix. A more appropriate fix is to
actually get uptime to work, which is a oneliner. See my patch posted
at http://patchwork.ozlabs.org/patch/387971/.

I'll mark your patch as Rejected in patchwork. Of course, if you
disagree, feel free to turn back your patch to the "New" state with an
explanation.

Thanks a lot for noticing this issue in the first place!

Thomas
-- 
Thomas Petazzoni, CTO, Free Electrons
Embedded Linux, Kernel and Android engineering
http://free-electrons.com


More information about the buildroot mailing list