[Buildroot] [PATCH 1/1] package/tvheadend: Add optional dependency to libiconv

Thomas Petazzoni thomas.petazzoni at free-electrons.com
Mon Jun 9 17:58:50 UTC 2014


Dear Bernd Kuhls,

On Mon,  9 Jun 2014 13:23:53 +0200, Bernd Kuhls wrote:

> BR2_TOOLCHAIN_BUILDROOT_LARGEFILE=y
> BR2_TOOLCHAIN_BUILDROOT_INET_IPV6=y
> BR2_PACKAGE_LIBICONV=y
> BR2_PACKAGE_TVHEADEND=y

You need libiconv because your toolchain does not have locale support.
Therefore, your Config.in should have something like:

	select BR2_PACKAGE_LIBICONV if !BR2_ENABLE_LOCALE

see all the other examples in Buildroot.

Thomas
-- 
Thomas Petazzoni, CTO, Free Electrons
Embedded Linux, Kernel and Android engineering
http://free-electrons.com


More information about the buildroot mailing list