[Buildroot] [PATCH 2 of 2] generic packages: rename FOO_CONFIGURE_OPTS into FOO_CONFIGURE_OPT
thomas.petazzoni at free-electrons.com
Sun Jul 27 13:22:23 UTC 2014
Dear Thomas De Schampheleire,
On Tue, 22 Jul 2014 21:21:32 +0200, Thomas De Schampheleire wrote:
> As FOO_MAKE_OPTS has been renamed to FOO_MAKE_OPT, this patch renames
> FOO_CONFIGURE_OPTS into FOO_CONFIGURE_OPT for symmetry reasons.
> Signed-off-by: Thomas De Schampheleire <thomas.de.schampheleire at gmail.com>
> Note: TARGET_CONFIGURE_OPTS has not been changed since the impact is very
> large. It would make sense to change it too, though, so let me know what you
Yeah, I'm a bit worried with the discrepancy between
TARGET_CONFIGURE_OPTS, TARGET_CONFIGURE_ARGS, HOST_CONFIGURE_OPTS and
HOST_CONFIGURE_ARGS that use the plural form, vs those per-package
My feeling is that the plural form looks more logical, so instead of
moving from _OPTS to _OPT, I'd rather like to see a move from _OPT to
_OPTS. But that indeed involves changing a *lot* of packages.
What do others think?
Thomas Petazzoni, CTO, Free Electrons
Embedded Linux, Kernel and Android engineering
More information about the buildroot