[Buildroot] Replace libev with libuv

Nimai Mahajan nimaim at gmail.com
Sat Jul 19 12:42:34 UTC 2014


Just tried it with your .mk Gustavo and Buildroot still doesn't like
it for some reason:

>>> libuv v0.11.26 Patching
echo "m4_define([UV_EXTRA_AUTOMAKE_FLAGS], [serial-tests])"
>/m4/libuv-extra-automake-flags.m4
/bin/bash: /m4/libuv-extra-automake-flags.m4: No such file or directory
make: *** [/home/user/Desktop/buildroot-2014.02/output/build/libuv-v0.11.26/.stamp_patched]
Error 1

I'm still on the 2014.02 version of Buildroot as everything is working
for us there currently but I don't think that should matter and your
echo statement there should be generating the
libuv-extra-automake-flags.m4 file so not sure why it's still broken.
I'll play around with it some more.

On Fri, Jul 18, 2014 at 7:36 PM, Nimai Mahajan <nimaim at gmail.com> wrote:
> Sending to whole group this time (sorry for any dupes, gmail is acting
> up)... Much appreciated Gustavo. This will help us out a lot. My biggest
> problem with any package in any distribution is cross compiling them is a
> pain because there is simply no standard and half of them are hacks and then
> its impossible to figure out. So thank you for the direct help.
>
> On Jul 18, 2014 10:02 AM, "Nimai Mahajan" <nimaim at gmail.com> wrote:
>>
>> Package works fine if on my Mint host I run ./autogen.sh, then
>> ./configure and then make which will properly generate static (.a) and
>> shared libraries (.so).
>>
>> If I use this kind of libuv.mk, I get errors in Buildroot:
>>
>> LIBUV_VERSION = v0.11.25
>> LIBUV_SITE = http://libuv.org/dist/$(LIBUV_VERSION)/
>> LIBUV_INSTALL_STAGING = YES
>> LIBUV_AUTORECONF = YES
>>
>> $(eval $(autotools-package))
>>
>> When trying to "make libuv":
>>
>> >>> libuv v0.11.25 Autoreconfiguring
>> aclocal: error: configure.ac:18: file
>> 'm4/libuv-extra-automake-flags.m4' does not exist
>> autoreconf:
>> /home/user/Desktop/buildroot-2014.02/output/host/usr/bin/aclocal
>> failed with exit status: 1
>> make: ***
>> [/home/user/Desktop/buildroot-2014.02/output/build/libuv-v0.11.25/.stamp_configured]
>> Error 1
>>
>> The problem is its not running the autogen.sh. How do I force this to
>> run? Is the only way still through <PKG_NAME>_POST_EXTRACT_HOOKS or
>> <PKG_NAME>_POST_PATCH_HOOKS?
>>
>>
>>
>> On Fri, Jul 18, 2014 at 9:32 AM, Gustavo Zacarias
>> <gustavo at zacarias.com.ar> wrote:
>> > On 07/18/2014 10:30 AM, Nimai Mahajan wrote:
>> >
>> >> Already tried that and it fails to build. I will give you the exact
>> >> error when I am by my PC again. And you are right both libraries are
>> >> for
>> >> different purposes, I guess it would have been more accurate to say
>> >> many
>> >> projects can make better use of libuv than libev. I just like that
>> >> libuv
>> >> is significantly better documented which in itself makes it more
>> >> usable.
>> >> I am using other autogen.sh packages as a template but they all seem to
>> >> have their own custom hooks which is what is confusing me. Thanks for
>> >> the help BTW.
>> >
>> > Hi.
>> > Keep the list cc'ed, you've got a better chance of getting help with
>> > everyone rather than just me, and also other people might be interested.
>> > Yes please do, normally AUTORECONF is enough but there are a couple of
>> > difficult packages that need some extra help.
>> > Regards.
>> >



More information about the buildroot mailing list