[Buildroot] Incorrect ABI setting on ubuntu 14.04LTS

Baruch Siach baruch at tkos.co.il
Thu Jul 3 09:24:20 UTC 2014


Hi Marco,

On Thu, Jul 03, 2014 at 12:20:10PM +0300, Baruch Siach wrote:
> On Thu, Jul 03, 2014 at 11:05:02AM +0200, Marco Pastorelli wrote:
> > I'm using buildroot 2014.05 to compile a BSP for a beaglebone. I'm using
> > linaro toolchain 2014.02
> > 
> > If I compile with ubuntu 12.04LTS everything works fine.
> > When I compile exactly the same project with another PC running ubuntu
> > 14.04LTS I run into this error:
> > 
> > >>> toolchain-external undefined Configuring
> > Incorrect ABI setting: EABIhf selected, but toolchain is incompatible
> > 
> > Does anybody knows which could be the problem?
> 
> What is the output of:
> 
> echo 'int main(void) {}' | arm-linux-gnueabihf-gcc -x c -o /dev/null
>
> on the problematic machine?

Forgot a dash. The command should be:

echo 'int main(void) {}' | arm-linux-gnueabihf-gcc -x c -o /dev/null -

baurch


-- 
     http://baruch.siach.name/blog/                  ~. .~   Tk Open Systems
=}------------------------------------------------ooO--U--Ooo------------{=
   - baruch at tkos.co.il - tel: +972.2.679.5364, http://www.tkos.co.il -



More information about the buildroot mailing list