[Buildroot] Binutils version used on MIPS

Markos Chandras Markos.Chandras at imgtec.com
Wed Jul 2 07:51:16 UTC 2014


On 07/01/2014 07:14 PM, Thomas Petazzoni wrote:
> Vicente, Markos,
> 
> For the MIPS architecture, the current default binutils version in the
> Buildroot internal toolchain backend is 2.21:
> 
>         prompt "Binutils Version"
>         depends on !BR2_arc
>         default BR2_BINUTILS_VERSION_2_21 if (BR2_mips || BR2_mipsel || BR2_sh)
>         default BR2_BINUTILS_VERSION_2_24 if BR2_microblaze || BR2_powerpc64le
>         default BR2_BINUTILS_VERSION_2_22
> 
> Do you know if there's a good reason to keep using 2.21, as opposed to
> a more recent version such as 2.23 or 2.24 ? It would be good to have a
> little bit of testing done with binutils 2.23 or 2.24 and if it's
> successful, bump the default version used on MIPS.
> 
> Thanks!
> 
> Thomas
> 
Hi Thomas,

No good reason and thanks for noticing. We will send a patch to use the
latest one by default.

-- 
markos



More information about the buildroot mailing list