[Buildroot] [PATCH] openswan: needs host-flex

Gustavo Zacarias gustavo at zacarias.com.ar
Mon Jul 21 12:20:16 UTC 2014


Although parser.l is shipped it seems it might get regenerated from
parser.y sometimes and an old installed flex might not be good enough.
Fixes:
http://autobuild.buildroot.net/results/e59/e5970eae28d01503d89a5d4e593711d7a27da8b5/

Signed-off-by: Gustavo Zacarias <gustavo at zacarias.com.ar>
---
 package/openswan/openswan.mk | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

diff --git a/package/openswan/openswan.mk b/package/openswan/openswan.mk
index 4d82b49..ce5bdfb 100644
--- a/package/openswan/openswan.mk
+++ b/package/openswan/openswan.mk
@@ -9,7 +9,7 @@ OPENSWAN_SITE = http://download.openswan.org/openswan
 OPENSWAN_LICENSE = GPLv2+, BSD-3c
 OPENSWAN_LICENSE_FILES = COPYING LICENSE
 
-OPENSWAN_DEPENDENCIES = host-bison gmp iproute2
+OPENSWAN_DEPENDENCIES = host-bison host-flex gmp iproute2
 OPENSWAN_MAKE_OPT = ARCH=$(BR2_ARCH) CC="$(TARGET_CC)" \
 	USERCOMPILE="$(TARGET_CFLAGS) -fPIE" INC_USRLOCAL=/usr \
 	USE_KLIPS=false USE_MAST=false USE_NM=false
-- 
1.8.5.5



More information about the buildroot mailing list