[Buildroot] [PATCH v5 1/4] Rename the variable "QUIET" to "BR_QUIET" for conformance

Fabio Porcedda fabio.porcedda at gmail.com
Tue Dec 23 10:51:14 UTC 2014

On Tue, Dec 23, 2014 at 11:17 AM, Thomas Petazzoni
<thomas.petazzoni at free-electrons.com> wrote:
> Hello,
> On Tue, 23 Dec 2014 09:54:58 +0100, Fabio Porcedda wrote:
>> Rename the variable "QUIET" to "BR_QUIET" accordingly to the convention
>> that internal variables should be named BR_XXX.
>> Signed-off-by: Fabio Porcedda <fabio.porcedda at gmail.com>
> Do we really want all internal variables to be named BR_* ? Like
> I'm not sure we want to do this, do we?

On Wed, Nov 26, 2014 at 10:35 PM, Yann E. MORIN <yann.morin.1998 at free.fr> wrote:
> Also, in retrospect, QUIET was not a really good name for this variable
> in the Makefile. It would have been better if it were named BR_QUIET.
> But that was introduced way before we decided on a variable naming
> convention... :-/

So which naming conventions Yann was referring?

Fabio Porcedda

More information about the buildroot mailing list