[Buildroot] [PATCH 3/3] ruby: bump to version 2.1.2

Peter Korsgaard jacmet at uclibc.org
Fri Aug 29 07:56:01 UTC 2014


>>>>> "Thomas" == Thomas Petazzoni <thomas.petazzoni at free-electrons.com> writes:

Hi,

 >> I don't really know much about Ruby. Is 2.1.x compatible with 1.9.x or
 >> is it like Python2/Python3?

 > I don't really know much about Ruby either. But, about Ruby 2.0,
 > Wikipedia says:

 > ""
 > Ruby 2.0 is intended to be fully backward compatible with Ruby 1.9.3.
 > As of the official 2.0.0 release on February 24, 2013, there were only
 > five known (minor) incompatibilities.
 > ""

 > And then, about Ruby 2.1, they say:

 > ""
 > Ruby 2.1.0 was released on Christmas Day in 2013.[31] The release
 > includes speed-ups, bugfixes, and library updates. Starting with 2.1.0,
 > Ruby is using semantic versioning.
 > ""

 > So I believe we can simply bump the ruby package to 2.1, and not bother
 > keeping two separate packages.

Ok, thanks - Committed to next.

-- 
Bye, Peter Korsgaard


More information about the buildroot mailing list