[Buildroot] [PATCH 00/12] toolchain: warn for unsafe library/header paths

Yann E. MORIN yann.morin.1998 at free.fr
Fri Aug 22 16:30:57 UTC 2014


Thomas, All,

On 2014-08-21 23:33 +0200, Thomas Petazzoni spake thusly:
> On Thu, 21 Aug 2014 22:30:29 +0200, Romain Naour wrote:
> > Also, BR_COMPILER_PARANOID_UNSAFE_PATH needs to be renamed to
> > BR2_COMPILER_PARANOID_UNSAFE_PATH to follow the naming scheme ?
> 
> No: BR2_* variables are Config.in options. Environment variables are
> BR_*.

Earlier this year in Brussels, we said we were to use BR2_ everywhere :
    http://elinux.org/Buildroot:DeveloperDaysFOSDEM2014

So Romain is right, that the environment variable should be renamed.

Regards,
Yann E. MORIN.

-- 
.-----------------.--------------------.------------------.--------------------.
|  Yann E. MORIN  | Real-Time Embedded | /"\ ASCII RIBBON | Erics' conspiracy: |
| +33 662 376 056 | Software  Designer | \ / CAMPAIGN     |  ___               |
| +33 223 225 172 `------------.-------:  X  AGAINST      |  \e/  There is no  |
| http://ymorin.is-a-geek.org/ | _/*\_ | / \ HTML MAIL    |   v   conspiracy.  |
'------------------------------^-------^------------------^--------------------'


More information about the buildroot mailing list