[Buildroot] [PATCH] package/lame: Fix compile on 32bit Intel with gcc-4.9.x

Thomas Petazzoni thomas.petazzoni at free-electrons.com
Sun Aug 17 12:55:08 UTC 2014


Dear Bernd Kuhls,

On Sun, 17 Aug 2014 12:53:00 +0200, Bernd Kuhls wrote:

> I understand, but removing the gcc version check, which would remove 
> support for xmmintrin.h in all i386 builds, would remove the mmx support 
> for lame on many builds, where it is not necessary.

Yes, understood. Maybe instead add some conditional code in lame to
enable the MMX stuff only with known working gcc versions? I think
there are some #define you can test to get the gcc version.

> Would something like this, extended to all external toolchains, be 
> acceptable?
> 
> --- a/toolchain/toolchain-external/Config.in
> +++ b/toolchain/toolchain-external/Config.in
> @@ -18,6 +18,7 @@ config BR2_TOOLCHAIN_EXTERNAL_LINARO_ARM
>         select BR2_INSTALL_LIBSTDCPP
>         select BR2_HOSTARCH_NEEDS_IA32_LIBS
>         select BR2_TOOLCHAIN_HEADERS_AT_LEAST_3_1
> +       select BR2_GCC_VERSION_4_9_X
>         help
>           Linaro toolchain for the ARM architecture. It uses Linaro
>           GCC 2014.05 (based on gcc 4.9), Linaro GDB 2014.05 (based on

That works only for "known" external toolchains: it won't work with
custom external toolchains.

Thomas
-- 
Thomas Petazzoni, CTO, Free Electrons
Embedded Linux, Kernel and Android engineering
http://free-electrons.com


More information about the buildroot mailing list