[Buildroot] [PATCH 1/1] wpa-supplicant: Add NL80211 support option

Thomas Petazzoni thomas.petazzoni at free-electrons.com
Fri Aug 8 08:38:46 UTC 2014


Dear Gustavo Zacarias,

On Thu, 07 Aug 2014 17:37:16 -0300, Gustavo Zacarias wrote:
> This is done automatically if the libnl package is selected/around.
> We really don't want to thread too thin into hostapd & wpa_supplicant
> config options.

Hum, so, Jean-Baptiste patch is adding CONFIG_DRIVER_NL80211 to the
configuration when libnl is available. But the current
wpa_supplicant.mk does (after removing the static lib special case)

ifeq ($(BR2_PACKAGE_LIBNL),y)
        WPA_SUPPLICANT_DEPENDENCIES += libnl
        WPA_SUPPLICANT_CONFIG_ENABLE += CONFIG_LIBNL32
else
        WPA_SUPPLICANT_CONFIG_DISABLE += CONFIG_DRIVER_NL80211
endif

So it enables CONFIG_LIBNL32 when libnl is used. Which is not exactly
the same thing. But interesting, in the else case, it's
CONFIG_DRIVER_NL80211 that gets disabled.

I'm a bit confused :)

Thanks,

Thomas
-- 
Thomas Petazzoni, CTO, Free Electrons
Embedded Linux, Kernel and Android engineering
http://free-electrons.com


More information about the buildroot mailing list