[Buildroot] [PATCH 2 of 2] infra: remove usage of pkgparentdir in favor of pkgdir

Thomas De Schampheleire patrickdepinguin at gmail.com
Tue Nov 12 13:49:55 UTC 2013

On Tue, Nov 12, 2013 at 2:42 PM, Arnout Vandecappelle <arnout at mind.be> wrote:
> On 12/11/13 12:32, Thomas De Schampheleire wrote:
>> Hi Thomas,
>> On Tue, Nov 12, 2013 at 12:09 PM, Thomas Petazzoni
>> <thomas.petazzoni at free-electrons.com> wrote:
>>> Dear Thomas De Schampheleire,
>>> On Tue, 12 Nov 2013 09:56:37 +0100, Thomas De Schampheleire wrote:
>>>>>   I think it's a better idea to choose a new name - if only to help
>>>>> people who are using this variable in custom packages. Or better
>>>>> yet, remove it completely - it's anyway not used anymore.
>>>> The only remaining place is in the foo-patch block, to get the
>>>> location of patches for that package.
>>>> That is outside the inner-generic-package, so we cannot use $(4)
>>>> anymore. How do you propose to solve that?
>>> Currently:
>>>   <foo>_DIR => build directory
>>>   <foo>_DIR_PREFIX => prefix of the package directory in Buildroot
>>>                       sources
>>>   <foo>_DL_DIR => location of the package download directory, for
>>>                   git/cvs downloads (apparently not used consistently)
>>> I think it would make a lot more sense to have:
>>>   <foo>_DIR => points to the package directory in Buildroot sources, e.g
>>>                package/busybox/ for Busybox. This would allow packages
>>>                to easily reference their own directory, to get access to
>>>                configuration files and others, instead of having to know
>>>                they are located in package/busybox/. This could also be
>>>                used in the patching step instead of the DIR_PREFIX thing.
>  As I mentioned before, I would prefer to not reuse the same name with a
> different meaning, because it may confuse users who have custom
> modifications that rely on that variable. So instead I'd remove the
> <foo>_DIR completely (so that it's pretty clear that this variable is empty
> if anybody still uses it), and instead use e.g. <foo>_BR_DIR for this
> purpose.

In that case I would prefer something like <foo>_PKG_DIR, instead of BR.

Best regards,

More information about the buildroot mailing list