[Buildroot] [PATCH] icu: Doesn't work on ARC yet

Peter Korsgaard jacmet at uclibc.org
Mon Nov 11 15:50:36 UTC 2013


>>>>> "Mischa" == Mischa Jonker <Mischa.Jonker at synopsys.com> writes:

> icu depends on __sync_sub_and_fetch and other atomic primitives that
> don't exist in the ARC toolchain yet.

Thanks, but you also need to:

- Add the !arc dependency to the comment line belo
- Propagate the dependency to icu's reverse dependencies:
git grep -l 'select BR2_PACKAGE_ICU'
package/beecrypt/Config.in
package/cppcms/Config.in
package/php/Config.ext
package/qt5/qt5base/Config.in
package/webkit/Config.in

Care to fix that and resend?

-- 
Bye, Peter Korsgaard


More information about the buildroot mailing list