[Buildroot] [Bug 6656] New: Build Qt5 with ccache

bugzilla at busybox.net bugzilla at busybox.net
Mon Nov 4 18:14:05 UTC 2013


           Summary: Build Qt5 with ccache
           Product: buildroot
           Version: unspecified
          Platform: PC
        OS/Version: Linux
            Status: NEW
          Severity: minor
          Priority: P5
         Component: Other
        AssignedTo: unassigned at buildroot.uclibc.org
        ReportedBy: espenfk at gmail.com
                CC: buildroot at uclibc.org
   Estimated Hours: 0.0


I have tried to get Buildroot (latest from git) to build Qt5 with ccache. Some
of the packages (at least) does it by defining the compiler to be something
like "$(CCACHE) $(TARGET_CROSS)". I tried to change the
package/qt/qt5base/qt5base.mk file to change the
output/build/qt5base-5.1.1/mkspecs/devices/linux-buildroot-g++/qmake.conf file
in such a way that ccache will work, but it fails.

It fails with:
Running configuration tests...
Failed to process makespec for platform 'devices/linux-buildroot-g++'
Project ERROR: CROSS_COMPILE needs to be set via -device-option
Could not read qmake configuration file
Error processing project file: /dev/null

I have tried many things from the most obious and easy: patch line 230 in
package/qt/qt5base/qt5base.mk to:

to use $(notdir $(TARGET_CROSS)) and adding $(dir $(TARGET_CROSS)) to the path
(also without ccache). But the only thing that seems to work is to have the
original setup and that does not work with ccache.

Configure bugmail: https://bugs.busybox.net/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are on the CC list for the bug.

More information about the buildroot mailing list