[Buildroot] [PATCH] usbmount: stop using blkid, use udev environment variables instead

Thomas Petazzoni thomas.petazzoni at free-electrons.com
Wed Jun 19 15:17:02 UTC 2013


Dear Sven Neumann,

On Wed, 19 Jun 2013 16:53:54 +0200, Sven Neumann wrote:

> > If this dependency is only for util-linux and you remove the select
> > BR2_PACKAGE_UTIL_LINUX below, you could get rid of this dependency.
> 
> Well, in fact the dependency still exists as usbmount needs udev and
> udev needs libblkid from util-linux. So perhaps udev should have a
> dependency on BR2_LARGEFILE && BR2_USE_WCHAR ?!

No, because usbmount has a *depends on* udev. So until udev is enabled,
you can't enable usbmount.

The propagation of "depends on" is needed when a package *selects*
another package.

Best regards,

Thomas
-- 
Thomas Petazzoni, Free Electrons
Kernel, drivers, real-time and embedded Linux
development, consulting, training and support.
http://free-electrons.com


More information about the buildroot mailing list