[Buildroot] [PATCH] toolchain/uClibc: remove deprecated version 0.9.31

Gustavo Zacarias gustavo at zacarias.com.ar
Thu Jun 13 13:55:56 UTC 2013


On 06/13/2013 05:55 AM, Simon Dawson wrote:

> Ah. I need uClibc 0.9.31 to support a long-running avr32-based
> project. The only option available now in Buildroot is 0.9.33, which
> for some reason results in a system that has unusably poor performance
> compared to the 0.9.31-based build.
> 
> Is there any chance that uClibc 0.9.31 can be retained in Buildroot?
> I'm not clear what the rationale for removing it is/was...

Rationale was the usual deprecation period and later removal.
0.9.31 isn't getting any younger, and lacks modern syscalls/functions -
i personally haven't been testing packages with that version for a while.
I'm pretty sure many modern packages will fail without some agressive
patch backporting.
I'm considering (BIG "considering", it's a non-priority for me) working
on a systemd/udev bump which will require backports for 0.9.32.x/33.x
and looking out for 0.9.31.x is not on my list.
Really, Atmel has sunk the AP7 (1), i'm sorry about that, but it's the
way life is for whatever strategic and/or commercial reason.
If vanilla toolchain components were in working shape we wouldn't be
talking about this.

Can't you keep your project running with buildroot 2013.05 or some other
release?
Regards.

(1)
http://www.atmel.com/About/Quality/obsolescence/obsolete_items.aspx?searchText=ap7



More information about the buildroot mailing list